Author Fuel pump not working  (Read 5361 times)

0 Members and 1 Guest are viewing this topic.

  • Offline VITO   il

    • CBF Newbie  ‐    7
    • *
    • Topic Author

    Offline VITO

    • CBF Newbie
    • *
    • Topic Author
    • Posts: 7
    • Fuel pump not working
    • Bike: CBF1000TA 2010
    • Country: il
    Fuel pump not working
    on: 19 March, 2023, 08:25:12 pm
    19 March, 2023, 08:25:12 pm
    Hi,
     I have a 2010 HONDA CBF1000TA
    And the fuel pump doesn't work. The relay on the fuel pump was replaced and the off switch on the handlebar was checked and it is working.
    I would appreciate your help ?
    Thanks

  • Offline Art   england

    • CBF Legend  ‐    2242
    • *****
      #1

    Offline Art

    • CBF Legend
    • *****
    • Posts: 2242
    • Bike: SC58 CBF1000 A-6
    • City / Town: Shoreditch
    • Country: england
    Re: Fuel pump not working
    Reply #1 on: 20 March, 2023, 06:50:33 am
    20 March, 2023, 06:50:33 am
    Not sure what a 'CBF1000TA' is  :027:  a 2010 could be a SC58 or a SC64 and the fuel pump wiring is different on both.

    Why was the Fuel Pump Relay replaced?

    Have you checked the 20A FI fuse?

    Can you hear the fuel pump prime when the ignition is switched on?




  • Offline Froggymanny   fr

    • CBF Pro  ‐    107
    • ***
      #2

    Offline Froggymanny

    • CBF Pro
    • ***
    • Posts: 107
    • If you can read this, you're too close
    • Bike: CBF1000F 2014
    • City / Town: Louveciennes
    • Country: fr
    Re: Fuel pump not working
    Reply #2 on: 20 March, 2023, 10:00:02 am
    20 March, 2023, 10:00:02 am
    Shalom Vito :-)
    Could be a silly answer but hey - I know my fuel pump won't start until I disengage the Technoglobe alarm that came with my bike. Bike would light up when I turn the key, ignition would start spinning if I hit the start button, but the engine would start and that is because the alarm cuts the power to the fuel pump.
    So if your bike is new to you, and it had an alarm that was removed when you purchased the bike... maybe look at the circuitry impacted by this operation. I'm making the hypothesis that if you had an alarm on that bike, you would certainly know it...
    Good luck.

  • Offline VITO   il

    • CBF Newbie  ‐    7
    • *
    • Topic Author
    • #3

    Offline VITO

    • CBF Newbie
    • *
    • Topic Author
    • Posts: 7
    • Fuel pump not working
    • Bike: CBF1000TA 2010
    • Country: il
    Re: Fuel pump not working
    Reply #3 on: 20 March, 2023, 03:15:11 pm
    20 March, 2023, 03:15:11 pm
    Hi,
    I don't have an alarm and it's off.

  • Offline VITO   il

    • CBF Newbie  ‐    7
    • *
    • Topic Author
    • #4

    Offline VITO

    • CBF Newbie
    • *
    • Topic Author
    • Posts: 7
    • Fuel pump not working
    • Bike: CBF1000TA 2010
    • Country: il
    Re: Fuel pump not working
    Reply #4 on: 20 March, 2023, 03:18:58 pm
    20 March, 2023, 03:18:58 pm
    Hi,
    I didn't touch the wiring.
    Had the fuel pump relay replaced by a central Honda garage who thought it was the problem.
    I checked the 20A FI fuse - it is fine and I replaced it with a new one.

    Can't hear the fuel pump start when the ignition is on.
    Best regards

  • Offline Art   england

    • CBF Legend  ‐    2242
    • *****
      #5

    Offline Art

    • CBF Legend
    • *****
    • Posts: 2242
    • Bike: SC58 CBF1000 A-6
    • City / Town: Shoreditch
    • Country: england
    Re: Fuel pump not working
    Reply #5 on: 20 March, 2023, 03:31:03 pm
    20 March, 2023, 03:31:03 pm
    I'd disconnect the fuel pump connector and jump the pump with 12v. If you hear the fuel pump prime its a wiring fault. If the fuel pump still doesn't prime remove the fuel pump and check the wiring between the connector and pump, if still no joy check the pump.

    What sort of Honda Garage replaces a relay because 'they thought' it was the problem?

    Relays are so easy to check, I trust they didn't charge you for that, I'd be looking for an alternative garage either way.
    Last Edit: 20 March, 2023, 03:37:28 pm by Art

  • Offline Art   england

    • CBF Legend  ‐    2242
    • *****
      #6

    Offline Art

    • CBF Legend
    • *****
    • Posts: 2242
    • Bike: SC58 CBF1000 A-6
    • City / Town: Shoreditch
    • Country: england
    Re: Fuel pump not working
    Reply #6 on: 21 March, 2023, 07:23:51 am
    21 March, 2023, 07:23:51 am
    If the fuel pump doesn't work when jumping it with 12v (Y/R positive & Bl/W or Bl negative) suspect the pump is faulty.

    If the fuel pump does work by jumping it with 12v suspect the Fuel System Circuit. Working from the power source to the pump check and test: 10A starter fuse; 20A FI IGN fuse; engine stop switch; right handlebar wiring 9 pin brown connector; lean angle sensor; engine stop relay; fuel cut off relay; fuel pump 3 pin black connector and all the associated circuit wiring including the A4, A5 & A21 connections to the Engine Control Module (ECM) .

    It can be a complicated diagnosis and a multimeter will be your only friend, work through the list step by step and you'll get there. If you’re allowed spanners and you haven't already, you may want to download the Honda Workshop Manual here. The sections on the 'FUEL SYSTEM (PGM FI)' and 'LIGHTS, METERS & SWITCHES' should be an interesting read.

    If that 'CBF1000TA' is a SC58 I've posted a CBF1000-A colour wiring diagram here or if its a SC64 I've posted a CBF1000-FA colour wiring diagram here, one or other you'll find useful.




     



    diverse-leafy